Letzten Beiträge Wechsle die Anzeige der Kommentare | Tastatur-Bedienung

  • mc um 18:02 am 6. January 2016 Permalink | antworten
    Begriffe: , , , , , ,   

    Raspberry Pi – /dev/ttyUSB0 ist weg 

    Zu Weihnachten habe ich von meinen Schwiegereltern einen “Raspberry Pi 2 Model B” geschenkt bekommen. Dieser sollte meinen Raspberry Pi (1) Model B ablösen – und hat das inzwischen auch getan 😉 Boah, ist der neue Pi schnell!! Zwischen den beiden Generationen liegen Welten!

    Der Umzug an sich war relativ unspektakulär: SD-Karte (boot) umgesteckt, USB Stick umgesteckt (root), alle Kabel umgesteckt, gebootet – fertig! Alles gut!

    Oder doch nicht alles. Ich stellte relativ schnell fest, dass meine Temperatursensoren nicht mehr erkannt wurden. /dev/ttyUSB0 war plötzlich nicht mehr vorhanden!??! “Na klar, muss am Umzug auf den neune Pi liegen!” dachte ich so bei mir und hab dann mal schnell ne Stunde Zeit verbraten, um den Port wieder herbeizuzaubern. Erfolglos. Leider. Dann rief mich das Bett…

    Heute Morgen ließ ich mir das Ganze nochmal durch den Kopf gehen und besann mich dann auf einen Ausspruch meines Schwagers Hilmar – seines Zeichens Mediziner: Koinzidenz bedingt keine Kausalität!

    Diesem Leitsatz folgend habe ich das Problem dann nochmal neu beleuchtet und festgestellt, dass die Sensoren schon seit ein paar Tagen außer Gefecht waren! Die Ursache war nach dieser Erkenntnis schnell behoben: ich hatte nach dem letzten apt-get update && apt-get upgrade vergessen auch ein rpi-update zu machen. Die Treiber/Module passten also nicht mehr zum Kernel. Aber warum war mir das nicht vorher aufgefallen? Naja, auch das ist leicht zu erklären: ich habe auf meinem Mailserver bei Strato zum Ende des letzten Jahres den Mailversand ausschließlich auf SSL umgestellt – und vergessen, die Konfiguration am Pi anzupassen. Er konnte mir also noch nicht mal per Mail mitteilen, dass er nicht mehr Mailen konnte…

    cum hoc ergo propter hoc!

     
  • mc um 14:19 am 12. November 2015 Permalink | antworten
    Begriffe: ,   

    shell:startup [wo ist mein Autostart??] 

    shell:startup bringt Dich

    in der englischen Version:
    %ALLUSERSPROFILE%\Start Menu\Programs\Startup\
    %USERPROFILE%\Start Menu\Programs\Startup\

    in der deutschen Version:
    %ALLUSERSPROFILE%\Startmenü\Programme\Autostart\
    %USERPROFILE%\Startmenü\Programme\Autostart\

     
  • mc um 13:01 am 31. October 2015 Permalink | antworten  

    Schön geworden! 

    Nach einem langen Abend, einer Nachtschicht und zwei, drei Tassen Kaffee beim Feinschliff ist es endlich soweit: http://www.ichzeigdirwiemanskocht.de erscheint in neuem Glanz! Moderner, schöner, heller, übersichtlicher und “responsive”. Die neue “Rezepte durchblättern”-Funktion ist was für lange Winter-Abende! Viel Spaß :) […und wer sich die Domain nicht merken kann: http://www.andreakocht.de funktioniert auch 😉 ]

     

     
  • mc um 10:17 am 17. October 2015 Permalink | antworten
    Begriffe: , , , truecrypt   

    TrueCrypt 7.2 auf Mac OS X 10.11 'El Capitain' 

    Fangen wir zuerst einmal mit dem “jaja, ich weiß” an: jaja, ich weiß!! TrueCrypt ist unsicher, Bitlocker ist viel besser, TrueCrypt ist der Antichrist und soll nicht mehr benutzt werden! Da es aber für mich die beste Lösung ist, benutze ich es einfach weiter. Bäh! …dachte ich so bei mir und versuchte die aktuelle Version (7.2) von TrueCrypt auf meinem Mac mit OS X 10.11 ‘El Captain’ zu installieren. Leider stieß ich dabei auf die folgende Fehlermeldung:

    TrueCrypt requires Mac OS X 10.4 or later

    Hhmm, nach meinem Verständnis ist 10.11 durchaus größer als 10.4? Egal, es ging halt nicht. Auch nicht mit lockereren Sicherheitseinstellungen. Google war aber auch, wie schon so oft, dieses Mal mein Freund und förderte die Lösung zu Tage: http://apple.stackexchange.com/questions/173879….

    Hier die Lösung nochmal in ein paar einfachen Schritten zusammengefasst:

    • TrueCrypt Installationspaket (TrueCrypt-7.2-Mac-OS-X.dmg) herunterladen, doppelklicken und mounten/einhängen
    • TrueCrypt 7.2.mpkg aus dem eingehängten Paket auf den Schreibtisch oder in den Download-Ordner kopieren
    • die kopierte Datei mit der rechten Maustaste (Sekundärklick) klicken und ‘Paketinhalt zeigen’ auswählen
    • die Datei Contents/distribution.dist rechts klicken und ‘Öffnen mit -> anderem Programm’ wählen
    • Mit eine Texteditor (TextEdit) öffnen
    • Die Zeilen 13 bis 18 entfernen. Aus

    vorher  wird    nachher

    • Jetzt die distribution.dist abspeichern und die Installation erneut anschmeißen – fertig!

    Warum die Prüfung in Zeile 13 allerdings zutrifft, verstehe ich nicht… inzwischen auch! Da wird kein numerischer, sondern ein String-Vergleich zwischen ‘10.11’ und ‘10.4’ durchgeführt…  *bähm*!

     
  • mc um 12:18 am 15. July 2015 Permalink | antworten
    Begriffe: , , , livehack   

    F:00 ist nicht die Kindersicherung! 

    An unserer Siemens Waschmaschine, Modell “Extraklasse E14-4G” machte es gestern Morgen *ploing* (also nur bildlich) und nach dem Öffnen der Türe wurde der Fehler “F:00” im Display angezeigt. Ein kurzes Bemühen von Google und einigen herzhaften Lachern später (es ist unglaublich, welche Horden von Schwachköpfen sich bei gutefrage.net tummeln) bin ich mit der Information, es müsse sich um die Kindersicherung handeln, in den Keller marschiert. Selbstverständlich hatte ich auch die Anleitung zum Aufheben der Kindersicherung dabei. Aber welche Überraschung – es funktionierte nicht! Also wieder an den Rechner – diesmal aber nicht bei den Honks (siehe oben), sondern in Heimwerkerforen recherchierend. Und da fand ich die gesuchte Information: “F:00” ist ein nicht genauer spezifizierter Fehler und wird daher auch nicht in der Bedienungsanleitung erwähnt. In meinem Fall musste der Fehler im Bereich der Türe zu finden sein, da zusätzlich zum F:00 noch das Tür-Symbol im Display prangerte. Also mal an der Tür gewackelt, fünf mal auf, fünf mal zu, ein Tropfen Öl ans Schloss und – keine Besserung. Zum Glück hatte ich aber noch irgendwo von geheimen Reset-Codes gelesen (und mir diese mal aufgeschrieben), mit denen man Prüfprogramme starten und den Fehlerspeicher resetten kann. Getreu dem Motto “kaputt ist sie ja schon” habe ich dann den Reset durchgeführt:

    • Türe zu
    • Programmwahlschalter auf 12 Uhr
    • Maschine einschalten
    • Programmwahlschalter auf 6 Uhr
    • Schleuderdrehzahlwahltaste drücken und halten
    • Programmwahlschalter auf 7 Uhr (bzw. einen ‘Klick’ in Uhrzeigerrichtung
    • Schleuderdrehzahlwahltaste loslassen

    Das Display zeigte dann “irgendwas” und nach aus- und wieder einschalten war die Maschine einsatzbereit. Viel Erfolg beim Nachmachen – selbstverständlich erfolgt das Ausprobieren auf eigene Gefahr! Und sollte jemand von den ganze Uhrzeiten da oben überfordert sein, dann wäre er wohl besser mal zur Bundeswehr gegangen. Segelschein ginge auch…

     
  • mc um 10:32 am 8. February 2015 Permalink | antworten
    Begriffe: , , , , gopro, , video   

    Sauerkrautsuppe ’15 

    Sauerkrautsuppe! Ne tolle Sache! Schmeckt super, macht satt und bringt das Gedärm in Fahrt. Insgesamt also eine tolle Sache für ein kleines Geburtstagsfest im engen Kreise der Familie. Und wenn man schon mal die Suppe nach Andreas Rezept kocht, dann kann man ja auch mal die Kamera draufhalten. Bzw. die Gopro im Zeitraffermodus mitlaufen lassen. Und raus kam dann das hier – viel Spaß!

    Die Musik gibts übrigens kostenlos bei http://www.jamendo.com.

     
  • mc um 21:03 am 23. January 2015 Permalink | antworten
    Begriffe: , , smart,   

    Smart: Fahrradträger-Numpsies mit Deckel! 

    Nun habe ich einen neuen Smart und auch einen neuen Fahrradträger. Der Fahrradträger ist nix anderes als der Grundträger mit Fahrradhalter. Warum ich das explizit erwähne? Damit Google beide Begriffe in den Index aufnimmt und so möglicherweise mehr Smart-Fahrer mit dem gleichen Problem hier landen! Problem? Ja, Problem! Der Grundträger wird an vier Punkten befestigt. Zwei davon sind spezielle Spezial-Numpsies, die in die Abschleppösen geschraubt und dann mit M8er Inbus-Schrauben (25mm lang )mit dem Träger verbunden werden. Soweit, so langweilig. Das Problem ist nun, dass eben diese Adapter für die Abschleppösen dunkelgrau sind und an meinem Smart – wenn der Fahrradträger nicht montiert ist – kacke aussehen. Irgendjemand meinte im Smart-Forum sogar, die komplette Rückansicht sei verschandelt. Und nun kommt meine geniale Erfindung ins Spiel: im Baumarkt gibt es Rohrstopfen, um z.B. offene Stuhlbeine zu verschließen! Richtig, das sind die Dinger, die man am Klapp-Campingtisch immer verliert. Der Viererpack kostet 1.49€ – und löst das Problem. Die 25mm Version passt perfekt auf den Abschleppösen-Adapter:

    IMG_1297

    Andrea, für Deine graue Stoßstange habe ich welche in schwarz besorgt 😉

     
  • mc um 12:53 am 17. December 2014 Permalink | antworten  

    Ubuntu 14.04 – fehlende MIBs / OIDs 

    Vor ein paar Jahren hatte ich das Problem schon einmal. Und jetzt, beim aufsetzen eines neuen Nagios-Servers schon wieder. Und aus fehlenden MIBs/ OIDs folgt ein laut hupendes Monitoring-System :/

    Aber nachdem ich die MIBs wieder einkommentiert (siehe obiger Artikel) und installiert (# sudo apt-get install snmp-mibs-downloader => siehe auch hier) hatte, funktionierte snmp wieder wie gewünscht :)

     
  • mc um 16:49 am 24. October 2014 Permalink | antworten
    Begriffe: , , ,   

    Nabaztag:tag – Hase unter dem Messer 

    Nachdem ich vor ein paar Wochen meinen Karotz gerootet und eine Doku dazu ins Netz gestellt habe (Hasenleaks quasi, *ngihi*), habe ich mir heute nochmal meinen zweiten, also eigentlich meinen ersten, Hasen vorgenommen. Seinerzeit zum stolzen Preis von ~150€ erworben, ist er seit der Abschaltung seiner Server in Frankreich nutzlos. Nu habe ich irgendwo im Netz die Idee geklaut, den Hasen auszuhöhlen und einen Raspbery Pi oder einen Arduino einzubauen. Beide könnten die Ohren drehen, den Lautsprecher befeuern und ein paar LEDs blinken lassen. Vielleicht baue ich auch einen Beschleunigungssensor ein und lasse den Hasen im Auto mitfahren. Mal sehen.
    Und als ich da so schraubte, fielen mir ein paar unverlötete Pins auf. Und siehe da – da ist sie, die serielle Schnittstelle des Nabastag:tag! Was aber viel geiler ist: während des Bootens posaunt der Hase den WLAN Schlüssel im Klartext auf die Konsole. Zum Glück ist diese Sicherheitslücke aber zu vernachlässigen…


    2014-10-24 17.15.50

    COM10 - PuTTY_2014-10-24_17-17-52

     
  • mc um 07:14 am 13. October 2014 Permalink | antworten
    Begriffe: , , ntfs,   

    ADS – Alternative Data Streams 

    [Vorweg: ich mache hier keine Witze über zappelige Kinder – das was jetzt kommt heißt wirklich ADS!]
    Nu steh ich da! Am Freitag haben wir einen (alten) virtualisierten Server außer Betrieb genommen und seine LUNS bzw. die VHDs an einen (neuen) virtualisierten Server gehangen. So konnten wir ca. 2TB an Daten reibungslos von einem Server zum anderen transferieren. Heute Morgen musste ich dann feststellen, dass sämtliche Datei vom neuen Server als “böse” eingestuft wurden:

    “Die Datei stammt von einem anderen Computer. Der Zugriff wurde aus Sicherheitsgründen eventuell blockiert.”

    Google brachte, außer ein paar Einträgen in sonderbaren Foren (bei denen ernsthaft empfohlen wurde, man solle den Zugriff auf die Dateien von Hand zulassen?! Seid Ihr nicht ganz dicht?!?!), nicht viel. Zwischen den Zeilen konnte man indes lesen, dass das irgendwas mit den alternativen Datenströmen – den ADS – zu tun haben muss. Und da fiel mir ein, dass ich doch da bei meinem Freund Mark Russinovich schon mal was zu gelesen hatte. Und siehe da: Microsoft daselbst bietet das passende Tool zum Auslesen und (rekursiven – juchu!) Entfernen der ADS an: technet.microsoft.com. Na, da ist der Tag doch schon gerettet!

     
c
Compose new post
j
Next post/Next comment
k
Previous post/Previous comment
r
antworten
e
bearbeiten
o
Show/Hide comments
t
Go to top
l
Go to login
h
Show/Hide help
shift + esc
Abbrechen